Getting Started with keyestudio

From Keyestudio Wiki
Jump to: navigation, search




Hello World.jpg

Hello World

Generally, teacher will teach us to write a simple Hello World example when starting to learn a programming language. Although it is only a basic introductory,it is a very important step for you to learn it. Please don't worry that you are not familiar with Arduino. Here you can learn the hello world program about Arduino: lighting up an LED. Now we take keyestudio UNO R3 Board as an example to help you how to light up an LED controlled by digital 13 pin. Before doing that, please make sure that you have downloaded the Arduino IDE and installed the keyestudio UNO R3 Driver successfully. Please refer to the following steps:


1.Connect keyestudio UNO R3 Board to the PC

Connect the keyestudio UNO R3 Board to your computer using the USB cable. The green power LED (labeled PWR) should be on.


2.Set Editor Language of Arduino

Open Arduino IDE, click File > Preferences to find out Editor Language, choose your own language, then close Arduino and open again.


11.png


Here, we choose English language.


12.png


3.Open the Blink Example

Open the LED blink example sketch: File->Examples->01.Basics->Blink.


Blink.png


4.Select Your Board

You'll need to select the entry in the Tools > Board menu that corresponds to your Arduino. Here we need to select Arduino Uno.


Board.png



5.Select Your Serial Port

Select the serial device of the Arduino board from the Tools | Serial Port menu.


Port.png



6.Upload the Program

Now, simply click "Upload" in the Arduino IDE. Wait for a few seconds - you should see the RX and TX LEDs on the board flashing. If the upload is successful, the message "Done uploading." will appear in the status bar.


Upload.png


7.Result

Waiting for a few seconds after the upload finished, you should see the pin 13 (L) LED on the board blinking. If it does, congratulations! You've gotten Arduino up-and-running.